App Center in myDatanet

Hello Community,

my server got updated to version 48v003 and now I want to use the app center. I successfully published a project via the rapidm2m.studio, install it and create a empty site without a serial number asigned to the project. Now here is the problem, when I try to asign a device to the empty site, I can’t select one. I tried to use the rookie guide stage 7 from my first IIoT project as a help, but I’m still stuck at this step.

Can somebody help me out?

Greetings
stegmaf

Hello @stegmaf,

which rapidM2M hardware do you use? You may have forgotten to set the “Required HW & SW” in the “Project Settings” under “Environment requirements”.

This entry must match the rapidM2M hardware on which the application is to be installed later. Outgoing from your last post I assume you are using a myDatalogEASY V3. “rapidM2M Easy HW3. *: 00v00” must be used for this hardware. HW3. * Means that the application can be installed on all devices from hardware version 3.0. 00v000 means that the application can be installed on all devices from firmware version 00v000. With these two settings you can specify special hardware and firmware requirements for your application.

You can determine this ID string required for the hardware as follows. In the rapidM2M portal, first click on “Devices” and then click on your device’s serial number.

Under “device” you will find the information about the hardware and firmware of the device.

In order for the changes in the project settings to be transferred to the site you have already created, you must first create a new tag in the rapidM2M Studio.

Log in to the rapidM2M portal and open the App Centre. Update the application installed on the rapidM2M portal using the green “update” button or change from “Store” to “Updates”.

Go to Applications, click on “Updates sites”, and select the site you created earlier.
image

Kind regards
Josef

Hello Josef,

thanks for the response, this did the job!
I changed the “Required HW & FW” to “rapidM2M Easy HW3.*:00v000”

I always used the suggested "rapidM2M M220 HW1:*00v000:
image

Greetings
stegmaf