I struggle to perform an OTA update

I have cloned the T32X Sensors App and brought it to the T32X via USB. Testbed.
Now I want to download this OTA to my device at partner.microtronics.com.

In the instructions < Stage 7  >
as documented under chapter 8. I have created a release. However, I can not perform steps 4-6.
I get the following display:
Bildschirmfoto 2021-12-17 um 10.42.56
When I want to assign the app with the V1 in the cloud to a free device I do not get my app offered. i.e. chapter 9. in the instructions, cannot be performed.

Hello @ritzeng,

usually after publishing the IoT-App it should be available for you to install on your device, if you selected “cloud.microtronics.com” as our backend.
But since this is not the case we can verify your application settings, in case some settings of your application do not align with the backend or your device.

I just cloned the application you mentioned and will show you the relevant parts, that you need to check:

  1. Open the project settings
  2. Check if your required backend is below or equal to that of your chosen backend. “cloud.microtronics.com” is currently (20.12.2021) on version 49v043 (this can be seen on the bottom right corner, if you log into your backend). So the required backend setting should be set to a version <= 49v043.
  3. Make sure your Required HW&FW is correct for the device that you are using. (00v000 means no specific firmware restriction)

Note: If you make a change to one of these settings the application has to be released again.

To release the application:

  1. Open up the rapidM2M Store settings
  2. Make sure the right backend is chosen for your application (“cloud.microtronics.com” should be correct, according to the tutorial you mentioned)
  3. Add release notes so the IoT App can be released

After these steps you should be able to release your application again.

Kind regards,
Stefan

Hello @ritzeng,

a short update to my previous answer.

The “Required backend” version should not be set to 49v999, because this would be an invalid configuration, since the “Required backend” would be higher as the chosen backend.
Therefore, the “Required backend” should always be <= to the version of your chosen backend.

For example, this would be a valid configuration for “cloud.microtronics.com” (10.01.2022):
image

Kind regards,
Stefan