T32x no connection

Hello, I have a problem with my T32 microcontroller. I wanted to run a demo application, but the microcontroller doesn’t recognise any connection. Here is a screenshot from the rapidM2M portal. Help would be greatly appreciated.

Hello @marcelortler,

I will try to give you some guidance on how you can solve your current issue.

  1. Since the T32x is a battery powered device, it is possible that the battery is in a low power state.
    The device has to come out of this state before it is usable again. On older firmware versions (< 00v008) this can take some time (multiple hours), but on a newer firmware version (>= 00v008) the device should charge more quickly when it is in a low power state.
    My recommendation here is that you keep the T32x connected to your pc for charging for a longer time.

  2. If the device is recognized by the device manager, but only as an unknown device, it is necessary to install the drivers for the device.
    The drivers for the device are included in the “DeviceConfig” application.
    If you follow the installation guide you should be able to install the necessary drivers.
    If the device is not correctly recognized, it will look like the following in the device manager:
    Device_Manager
    After the driver installation you can verify the USB connection to device with the guide explained here.

  3. In case the device is still not recognized by the rM2M Studio and you see the following warning message, please follow the linked instructions to manually install the necessary USB driver.
    image

Kind regards,
Stefan

Hello @Stefan,
after trying those three methods, the T32x has still not responded.
Help would be greatly appreciated.

Hello @marcelortler,

I see, there are two more things that you could try to get the T32x to respond via USB.

  1. You can try to unplug the internal battery of the T32x and plug the battery back in after a few seconds.
    A guide on how to open the case of the T32x and remove the battery can be found here. (From page 47 onwards)

  2. If possible, also try to use another USB-C cable.
    I had a similar issue, when I tried to use a USB-C cable from my smartphone. To solve the issue I ordered a USB-C cable from “RS Components” with the RS stock number 116-9372, which did work, and I was able to successfully connect the T32x to my PC.

Kind regards,
Stefan